Glossary

CLI commands - Classes & subnetting of networks

 Extras


Configuring computer network means that the configuration performs active network equipment in the network, and designed according to the accepted scheme. Sometimes it is used to set the serial RS 232C port on a computer connected with a special connection to the network device. Can be used and different types of connectors, but cable to connect the network devices and computers strictly dedicated supplied with the network device. Via 'Terminal' ('Hyper Terminal' in Windows XP OS) software is possible access to the active network device and giving command contained in the operating system network device is performed to configure. When to a network device is assigned an address that is in line with the creation of a network diagram-firm institutions, can be via a web interface, using a graphical representation of the GUI (Graphic User Interface), configuring a network access device, but not to the full extent as the command line - CLI (Command Line Interface). CLI is the primary way to configure the device.

 Cisco - logo So firm Cisco in their network devices using IOS (Internetwork Operating System) that allows you to configure the network devices on both these ways. The following provides a little manual that shows how to look at TCP / IP in relation to the OSI network model concept, useful commands for Windows OS contains a snapshot of the set parameters of your computer and control the communication network, a list of computer classes, auxiliary tables for successful subnetting the network, the commands for configuring Cisco routers and switches. Commands allow the network device is defined by the administrator name and its password to configure the communication protocols and a variety of security mechanisms.

=======================================================================================
 TCP / IP suite of protocols according to layers of the OSI model
=======================================================================================
       OSI                    TCP / IP                        Protocols           PDU
----------------- ------------------------------- --------------------------- ---------
 7. Application    Application                     Telnet, FTP, SMTP 
 6. Presentation                                   ASCII, GIF , JPEG           D A T A
 5. Session                                        Socket Interface (HD, FD)   Data
 4. TRANSPORT      TRANSPORT (Host2Host/End2End)   TCP, UDP                    SEGMENT
 3. Network        Internet                        IP                          PACKET
 2. Data Link      Network Access (Host2Net)
      LLC (802.2)                                  SAP, SNAP
      MAC (802.3)                                                              FRAME
 1. Physical Bits
=======================================================================================
=======================================================================================
 Classes of of computer networks and subnetting
=======================================================================================
 Commands in the Command Prompt window of PC
---------------------------------------------
 ipconfig /all
 arp -a
 netstat -n
 ping          (network layer - 3)
 tracert
 telnet    (application layer - 7)

=======================================================================================
 Network classes - computer addresses (public and private)
-------------------------------------------------------------------------
 Network addressing with IPv4 (32 bits)

 Class   1      8      16      24      32
         |......|.......|.......|.......|
         .      .       .       .       .
   A     |0.Net.|.........hosts.........|
   B     |10...Network..|.....hosts.....|---- publice networks
   C     |110........Network....|.hosts.|
         .                              .
   D     |1110....Multicast address.....|
   E     |1111.........Reserved.........|
-------------------------------------------------------------------------
                          CIDR           Leading bits
                        notation          (HOBits)  
   A       1-126.h.h.h   IP/8                0
   B     128-191.N.h.h   IP/16               10
   C     192-223.N.N.h   IP/24               110
  -----------------------------
   D     224-239.n.n.n   IP/32               1110             (Multicast) 
   E     240-255.n.n.n   IP/32               1111              (Reserved)
-------------------------------------------------------------------------
  Network 127 is reserved for the loopback (127.0.0.1) and testing
-------------------------------------------------------------------------
         224.0.0. 5 = OSPF DR i BDR                           (Hello-LSA)
         224.0.0. 6 = OSPF ostali
         224.0.0. 9 = RIPv2
         224.0.0.10 = EIGRP      (Dual-Hello), SR (routing and top table)
                                     , FS (top.table)
                                     , table of neighbor
-------------------------------------------------------------------------
   A      10.  0.0.0 -  10.255.255.255  |
   B     172. 16.0.0 - 172. 31.255.255  |---- private networks
   C     192.168.0.0 - 192.168.255.255  |
---------------------------------------------------------------------------------------

An example of networking computers and computing devices in a private class C is shown
in Chapter 7.4.5, in Figure 7.4.16.

   The most commonly used ports (number and purpose)
|------|-----|-----|-----|------|-----|-----|-----|-----|-----|-----|-----|-----|-----|
|Port  |  20 |  21 |  22 |   23 |  25 |  53 |  69 |  80 | 119 | 110 | 161 | 443 | 531 |
|------|-----|-----|-----|------|-----|-----|-----|-----|-----|-----|-----|-----|-----|
|Purp. |FTP-D| FTP | SSH |Telnet| SMTP| %DNS|*TFTP| HTTP| NNTP| POP3|*SNMP|HTTPS| CHAT|
|------|-----|-----|-----|------|-----|-----|-----|-----|-----|-----|-----|-----|-----|
  *UDP %UDP+TCP
=======================================================================================

   Decade-hexadecimal-binary numbers
|-----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|
|Dek. | 15 | 14 | 13 | 12 | 11 | 10 |  9 |  8 |  7 |  6 |  5 |  4 |  3 |  2 |  1 |  0 |
|-----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|
|Hex. |  F |  E |  D |  C |  B |  A |  9 |  8 |  7 |  6 |  5 |  4 |  3 |  2 |  1 |  0 |
|-----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|
|Bin. |1111|1110|1101|1100|1011|1010|1001|1000|0111|0110|0101|0100|0011|0010|0001|0000|
|-----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|

   Decade-hexadecimal-binary numbers with leading zeros
|----|-----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|
|Dek.|16384|8192|4096|2048|1024| 512| 256| 128| 64 | 32 | 16 |  8 |  4 |  2 |  1 |  0 |
|----|-----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|
|Hex.| 4000|2000|1000| 800| 400| 200| 100| 80 | 40 | 20 | 10 |  8 |  4 |  2 |  1 |  0 |
|----|-----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|
|    | 0100|0010|0001|    |    |    |    |    |    |    |    |    |    |    |    |    |
|Bin.| 0000|0000|0000|1000|0100|0010|0001|    |    |    |    |    |    |    |    |    |
|    | 0000|0000|0000|0000|0000|0000|0000|1000|0100|0010|0001|    |    |    |    |    |
|    | 0000|0000|0000|0000|0000|0000|0000|0000|0000|0000|0000|1000|0100|0010|0001|0000|
|----|-----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|----|

   Subnetting B-class (128-191.N.h.h IP/16)
|----------|-----|-----|----|----|----|----|----|----| |----|----|----|----|----|-----|
|Format    | /17 | /18 | /19| /20| /21| /22| /23| /24| | /25| /26| /27| /28| /29|  /30|
|----------|-----|-----|----|----|----|----|----|----| |----|----|----|----|----|-----|
| Net      | 128 | 192 | 224| 240| 248| 252| 254| 255| | 255| 255| 255| 255| 255|  255|
| MASK     |   0 |   0 |   0|   0|   0|   0|   0|   0| | 128| 192| 224| 240| 248|  252|
|----------|-----|-----|----|----|----|----|----|----| |----|----|----|----|----|-----|
|Net-Bits  |   1 |   2 |  3 |  4 |  5 |  6 |  7 |  8 | |  9 | 10 | 11 | 12 | 13 |  14 |
|Host-Bits |  15 |  14 | 13 | 12 | 11 | 10 |  9 |  8 | |  7 |  6 |  5 |  4 |  3 |   2 |
|----------|-----|-----|----|----|----|----|----|----| |----|----|----|----|----|-----|
|          | 1000| 1100|1110|1111|1111|1111|1111|1111| |1111|1111|1111|1111|1111| 1111|
|Binary    | 0000| 0000|0000|0000|1000|1100|1110|1111| |1111|1111|1111|1111|1111| 1111|
|          | 0000| 0000|0000|0000|0000|0000|0000|0000| |1000|1100|1110|1111|1111| 1111|
|          | 0000| 0000|0000|0000|0000|0000|0000|0000| |0000|0000|0000|0000|1000| 1100|
|----------|-----|-----|----|----|----|----|----|----| |----|----|----|----|----|-----|
|Range     |  128|   64|  32|  16|   8|   4|   2|   1| | 128|  64|  32|  16|   8|    4|
|----------|-----|-----|----|----|----|----|----|----| |----|----|----|----|----|-----|
|T-subnets |   *2|    4|   8|  16|  32|  64| 128| 256| | 512|1024|2048|4096|8192|16384|
|U-SUBNETS |   * |    2|   6|  14|  30|  62| 126| 254| | 510|1022|2046|4094|8190|16382|
|----------|-----|-----|----|----|----|----|----|----| |----|----|----|----|----|-----|
|T-hosts   |32768|16384|8192|4096|2048|1024| 512| 256| | 128|  64|  32|  16|   8|    4|
|U-HOSTS   |32766|16382|8190|4094|2046|1022| 510| 254| | 126|  62|  30|  14|   6|    2|
|----------|-----|-----|----|----|----|----|----|----| |----|----|----|----|----|-----|
  * If by IOS router supported zero subnets can be used specified
---------------------------------------------------------------------------------------

Example of subnetting private class B is shown in the Chapter 4.4.4.

---------------------------------------------------------------------------------------

   Subnetting B-class (192-223.N.N.h IP/24)
 |--------------------|-----|-----|-----|-----|-----|-----|-----|-----|
 | Format             | /25 | /26 | /27 | /28 | /29 | /30 |     |     |
 |--------------------|-----|-----|-----|-----|-----|-----|-----|-----|
 | Net Mask           | 128 | 192 | 224 | 240 | 248 | 252 | 254 | 255 |
 |--------------------|-----|-----|-----|-----|-----|-----|-----|-----|
 | Bits borrowed - NB |  1  |  2  |  3  |  4  |  5  |  6  |  7  |  8  |
 | Bits for host - HB |  7  |  6  |  5  |  4  |  3  |  2  |  1  |  0  |
 |--------------------|-----|-----|-----|-----|-----|-----|-----|-----|
 |                    | 1000| 1100| 1110| 1111| 1111| 1111| 1111| 1111|
 | Binary             | 0000| 0000| 0000| 0000| 1000| 1100| 1110| 1111|
 |--------------------|-----|-----|-----|-----|-----|-----|-----|-----|
 | Range              | 128 |  64 |  32 |  16 |   8 |   4 |   2 |   1 |
 |--------------------|-----|-----|-----|-----|-----|-----|-----|-----|
 | Total subnets      |  *2 |   4 |   8 |  16 |  32 |  64 |    NB     |
 | Usable SUBNETS     |  *  |   2 |   6 |  14 |  30 |  62 |   2 - 2   |
 |--------------------|-----|-----|-----|-----|-----|-----|-----------|
 | Total hosts        |*128 |  64 |  32 |  16 |   8 |   4 |    HB     |
 | Usable HOSTS       | 126 |  62 |  30 |  14 |   6 |   2 |   2 - 2   |
 |--------------------|-----|-----|-----|-----|-----|-----|-----------|
 | IP-IP hosts RANGE  |  *1 |   1 |   1 |   1 |   1 |   1 |           |
 | for first SUBNET   |*126 |  62 |  30 |  14 |   6 |   2 |           |
 |--------------------|-----|-----|-----|-----|-----|-----|-----------|
  * If by IOS router supported zero subnets can be used specified

   Subnetting B-class /27 (3 bits borrowed)
 |-----|---------------|-----------|----------|
 | Broj|   Subnet ID   | IP-Brojevi| Boadcast |  Addresses with zero "0"
 |Mreže|   (NET-MASK)  | HOSTOVA   |    ID    |  are reserved for the NETWORK
 |-----|---------------|-----------|----------|  (bits of host part)
 |  0  |x.x.x.(000)  0 |   1 - 30  |x.x.x. 31 | 
 |  1  |x.x.x.(001) 32 |  33 - 62  |x.x.x. 63 |  Addresses with one  "1"
 |  2  |x.x.x.(010) 64 |  65 - 94  |x.x.x. 95 |  are reserved for
 |  3  |x.x.x.(011) 96 |  97 - 126 |x.x.x.127 |  BROADCAST of NETWORK
 |  4  |x.x.x.(100)128 | 129 - 158 |x.x.x.159 |  (bits of host part)
 |  5  |x.x.x.(101)160 | 161 - 190 |x.x.x.191 |
 |  6  |x.x.x.(110)192 | 193 - 222 |x.x.x.223 |
 |  7  |x.x.x.(111)224 | 225 - 254 |x.x.x.255 |
 |-----|---------------|-----------|----------|
  'Subnet' mask of subnet /27 is: 255.255.255.224 (x.x.x.11100000)

  Sub-subnetting C-klasa /27 at /30 for serial links
 |-----|---------|-------|----------|---------|
 | Pod |Sub-Subn.|  IP   |Sub-Subnet|   IP    | 
 |Mreža|   ID    |LINKOVA|    ID    | LINKOVA |
 |-----|---------|-------|----------|---------|  Addresses with zero "......00"
 |  0  |x.x.x.32 | 33-34 |x.x.x.192 | 193-194 |  are reserved for the SUB-NET
 |  1  |x.x.x.36 | 37-38 |x.x.x.196 | 197-198 |  (bits of host part)
 |  2  |x.x.x.40 | 41-42 |x.x.x.200 | 201-202 |
 |  3  |x.x.x.44 | 45-46 |x.x.x.204 | 205-206 |  Addresses with one  "......11"
 |  4  |x.x.x.48 | 49-50 |x.x.x.208 | 209-210 |  are reserved for
 |  5  |x.x.x.52 | 53-54 |x.x.x.212 | 213-214 |  BROADCAST for SUB-NET
 |  6  |x.x.x.56 | 57-58 |x.x.x.216 | 217-218 |  (bits of host part)
 |  7  |x.x.x.60 | 61-62 |x.x.x.220 | 221-222 |
 |-----|---------|-------|----------|---------|
  'Subnet' mask of sub-subnet /30 is: 255.255.255.252 (x.x.x.11111100)
---------------------------------------------------------------------------------------

Example of subnetting private class C is shown in the Chapter 4.5.5.

---------------------------------------------------------------------------------------
  Different tables of subnetting only for 'Usable SUBNETS' i 'Usable HOSTS'

   Subnetting B-class (128-191.N.h.h IP/16)
 |------|-------|-----------------|---------|-------|-------|
 |Format|OF Bits|   Subnet Mask   | Subnets | Hosts | Range |
 |------|-------|-----------------|---------|-------|-------|
 |  /17 |   *1  | 255.255.128.  0 |     *2  | 32766 |  128  |
 |------|-------|-----------------|---------|-------|-------|
 |  /18 |    2  | 255.255.192.  0 |      2  | 16382 |   64  |
 |------|-------|-----------------|---------|-------|-------|
 |  /19 |    3  | 255.255.224.  0 |      6  |  8190 |   32  |
 |------|-------|-----------------|---------|-------|-------|
 |  /20 |    4  | 255.255.240.  0 |     14  |  4094 |   16  |
 |------|-------|-----------------|---------|-------|-------|
 |  /21 |    5  | 255.255.248.  0 |     30  |  2046 |    8  |
 |------|-------|-----------------|---------|-------|-------|
 |  /22 |    6  | 255.255.252.  0 |     62  |  1022 |    4  |
 |------|-------|-----------------|---------|-------|-------|
 |  /23 |    7  | 255.255.254.  0 |    126  |   510 |    2  |
 |------|-------|-----------------|---------|-------|-------|
 |  /24 |    8  | 255.255.255.  0 |    254  |   254 |    1  |
 |------|-------|-----------------|---------|-------|-------|
 |------|-------|-----------------|---------|-------|-------|
 |  /25 |    9  | 255.255.255.128 |    510  |  126  |  128  |
 |------|-------|-----------------|---------|-------|-------|
 |  /26 |   10  | 255.255.255.192 |   1022  |   62  |   64  |
 |------|-------|-----------------|---------|-------|-------|
 |  /27 |   11  | 255.255.255.224 |   2046  |   30  |   32  |
 |------|-------|-----------------|---------|-------|-------|
 |  /28 |   12  | 255.255.255.240 |   4094  |   14  |   16  |
 |------|-------|-----------------|---------|-------|-------|
 |  /29 |   13  | 255.255.255.248 |   8190  |    6  |    8  |
 |------|-------|-----------------|---------|-------|-------|
 |  /30 |   14  | 255.255.255.252 |  16382  |    2  |    4  |
 |------|-------|-----------------|---------|-------|-------|
  * If by IOS router supported zero subnets can be used specified

   Subnetting C-class (192-223.N.N.h IP/24)
 |------|-------|-----------------|---------|-------|-------|
 |Format|OF Bits|   Subnet Mask   | Subnets | Hosts | Range |
 |------|-------|-----------------|---------|-------|-------|
 |  /25 |   *1  | 255.255.255.128 |    *2   |  126  |  128  |
 |------|-------|-----------------|---------|-------|-------|
 |  /26 |    2  | 255.255.255.192 |     2   |   62  |   64  |
 |------|-------|-----------------|---------|-------|-------|
 |  /27 |    3  | 255.255.255.224 |     6   |   30  |   32  |
 |------|-------|-----------------|---------|-------|-------|
 |  /28 |    4  | 255.255.255.240 |    13   |   14  |   16  |
 |------|-------|-----------------|---------|-------|-------|
 |  /29 |    5  | 255.255.255.248 |    30   |    6  |    8  |
 |------|-------|-----------------|---------|-------|-------|
 |  /30 |    6  | 255.255.255.252 |    62   |    2  |    4  |
 |------|-------|-----------------|---------|-------|-------|
  * If by IOS router supported zero subnets can be used specified
=======================================================================================
=======================================================================================
 Commands for configuring of Cisco router
=======================================================================================
 UEM = User Exec Mode                         (view only)
 PEM = Privileged Exec Mode                     (enabled)
 GCM = Global Configuration Mode          (configuration)
-------------- UEM -> PEM -> GCM -> SCM -----------------
 SCM = Specific Configuration Mode
---------------------------------------
 ICM = Interface CM      (part of SCM)
 LCM = Line CM           (part of SCM)
 RCM = Router CM         (part of SCM)
---------------------------------------------------------
 SCM #exit --> GCM
 SCM #<CTRL>+<Z> --> PEM
---------------------------------------------------------------------------------------
 Commands insight into the configuration
-----------------------------------------
 (PEM) ROUTER#show version
 (PEM) ROUTER#show startup-config                                               (NVRAM)
 (PEM) ROUTER#show run
 (PEM) ROUTER#show running-config                                                 (RAM)
 (PEM) ROUTER#show cdp
 (PEM) ROUTER#show cdp neighbors
 (PEM) ROUTER#show interfaces
 (PEM) ROUTER#show ip protocols
 (PEM) ROUTER#show ip interface [brief]
 (PEM) ROUTER#show ip route [eigrp]
 (PEM) ROUTER#show ip eigrp neighbors
 (PEM) ROUTER#show ip eigrp interfaces
 (PEM) ROUTER#show ip eigrp topology { | | }
 (PEM) ROUTER#show ip eigrp topology all-links
 (PEM) ROUTER#show ip eigrp traffic
 (PEM) ROUTER#show ip ospf
 (PEM) ROUTER#show ip ospf neighbor [detail]
 (PEM) ROUTER#show ip ospf interface [fastethernet 0]
 (PEM) ROUTER#show ip ospf database
 (PEM) ROUTER#show frame-relay pvc
 (PEM) ROUTER#show frame-relay map
 (PEM) ROUTER#show frame-relay lmi
 (PEM) ROUTER#show ip dhcp binding
 (PEM) ROUTER#show ip dhcp server statistic
 (PEM) ROUTER#show ip nat translations
---------------------------------------------------------------------------------------
 Initial setup of router
----------------------------------
 (UEM) ROUTER>enable
 (PEM) ROUTER#show running-config
 (PEM) ROUTER#configure terminal
 (GCM) ROUTER(config)#
 (GCM) ROUTER(config)#hostname BUZDO
 (GCM) BUZDO(config)#
 (GCM) BUZDO(config)#banner motd     # Routers of NETWORK_NAME - Enter into the BUZDO #
 (GCM) BUZDO(config)#ip http server
 (GCM) BUZDO(config)#
 (GCM) BUZDO(config)#ip host /name of 1. Router/ /IP of 1. Router/
 (GCM) BUZDO(config)#ip host /name of 2. Router/ /IP of 2. Router/
 (GCM) BUZDO(config)#ip host /name of 1. Switch/ /IP of 1. Switch/
 (GCM) BUZDO(config)#
 (GCM) BUZDO(config)#exit
 (PEM) BUZDO#copy running-config startup-config
 (PEM) BUZDO#exit
 (UEM) BUZDO>
---------------------------------------------------------------------------------------
 PASSWORD_ for GCM (ordinary and coded that 'kill' ordinary)
-------------------------------------------------------------
 (GCM) BUZDO(config)#enable password PASSWORD_1
 (GCM) BUZDO(config)#enable secret PASSWORD_2
 (GCM) BUZDO(config)#exit
 (PEM) BUZDO#
---------------------------------------------------------------------------------------
 PASSWORD_ for cosole (Enter into UEM)
--------------------------------------
 (GCM) BUZDO(config)#line console 0
 (LCM) BUZDO(config-line)#password PASSWORD_3
 (LCM) BUZDO(config-line)#login
 (LCM) BUZDO(config-line)#<CTRL>+<Z>
 (PEM) BUZDO#
---------------------------------------------------------------------------------------
 PASSWORD_ for modem (Enter into UEM)
--------------------------------------
 (GCM) BUZDO(config)#line vty 0 4
 (LCM) BUZDO(config-line)#password PASSWORD_4
 (LCM) BUZDO(config-line)#login
 (LCM) BUZDO(config-line)#<CTRL>+<Z>
 (PEM) BUZDO#
---------------------------------------------------------------------------------------
 Save configuration to NVRAM and vice versa
--------------------------------------------
 (PEM) BUZDO#copy running-config startup-config (RAM-NVRAM)
 (PEM) BUZDO#copy run start
 (PEM) BUZDO#reload
 (UEM) BUZDO>enable
 (PEM) BUZDO#
 (PEM) BUZDO#copy startup-config running-config
 (PEM) BUZDO#copy start run
---------------------------------------------------------------------------------------
 A.D. = Administrative Distance
 C2I  = Count To infinity
 S-H  = Split Horizon with Poison Reverse
 H-D  = Hold-Down Timer
 Upd. = Periodicni update
 T-Up = Trigered update
 L.B. = Load Balancing - equal paths - unequal paths                (maximum / default)
 R.S. = Route Summarization                                 (transfer of 'subnet' mask)
 Alg. = Algoritam

 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | TIP RUTE       | A.D.|Cnt2|Spl-|H-DW|Per.|Trg.|L.B.|L.B.|Met.|HOP |VLSM|Algor.|
 | (PROTOCOLA)    |     |Inf.|Hor.|Timr|Upd.|Upd.|EQP |UEQP|    |    |R.S.|      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | Connected      |   0 |    |    |    |    |    |    |    |    |    |    |      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | Static         |   1 |    |    |    |    |    |    |    |    |    |    |      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | EIGRP Summary  |   5 |    |    |    |    |    |    |    |    |    |    |      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | External BGP   |  20 |    |    |    |    |    |    |    |    |    |    |      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | EIGRP          |  90 |    |  * |    |5s-H|  * | 6/4|  * |Comp| 224|  * |Dual-H|
 |----------------|-----|----|----|----|----|----|----|----|----| -- |----|------|
 | IGRP           | 100 |  * |  * |  * | 90s|  * |  * |  * |Comp| 255|    |      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | OSPF           | 110 |    |    |    | 30m|  * |  * |    |Cost| 200|  * |Lsa-H |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | IS-IS          | 115 |    |    |    |    |  * |  * |    |Cost|1024|  * |      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | RIPv1          | 120 |  * |  * |  * | 30s|  * | 6/4|    |Hop |  15|    |      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | RIPv2          | 120 |  * |  * |  * | 30s|  * | 6/4|    |Hop |  15|  * |      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | External EIGRP | 170 |    |    |    |    |    |    |    |    |    |    |      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | Internal BGP   | 200 |    |    |    |    |    |    |    |    |    |    |      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 | Unknown        | 255 |    |    |    |    |    |    |    |    |    |    |      |
 |----------------|-----|----|----|----|----|----|----|----|----|----|----|------|
 EIGRP supports = IP, AppleTalk, IPX (multi-protocol)

 OSPF Cost      = 10 (bps) / BW (bps)             (OSPF must have 'loopback' interface)
 SP-Tree Cost   = suma BW
---------------------------------------------------------------------------------------
 Defining a serial interface and FE interface (IF)
---------------------------------------------------
 (PEM) BUZDO#
 (PEM) BUZDO#configure terminal
 (GCM) BUZDO(config)#
 (GCM) BUZDO(config)#interface serial 0/0
 (ICM) BUZDO(config-if)#clock rate 56000                                 (only for DCE)
 (ICM) BUZDO(config-if)#description serial connection to the DTE-s0
 (ICM) BUZDO(config-if)#ip address /IF-IP/ /SNM/
 (ICM) BUZDO(config-if)#no shutdown
 (ICM) BUZDO(config-if)exit
 (GCM) BUZDO(config)#
 (GCM) BUZDO(config)#interface fastethernet 0/0
 (ICM) BUZDO(config-if)#ip address /IF-IP/ /SNM/
 (ICM) BUZDO(config-if)#description LAN of BUZDO
 (ICM) BUZDO(config-if)#no shutdown
 (ICM) BUZDO(config-if)exit
 (GCM) BUZDO(config)#<CTRL>+<Z>
 (PEM) BUZDO#copy running-config startup-config
 (PEM) BUZDO#
---------------------------------------------------------------------------------------
 Defining static and default route (GWLR)
------------------------------------------------
 BUZDO(config)#ip route /NW-IP destinatione/ /SNM destination/ /S-IF | IP-NextHOP/ [AD]
 BUZDO(config)#
 BUZDO(config)#ip route 0.0.0.0 0.0.0.0 /S-IF | IP-NextHOP/
 BUZDO(config)#
 BUZDO(config)#ip default-network /NW-IP of destination/     (address of Router-Serial)
---------------------------------------------------------------------------------------
 Simulation of Internet and specific location
----------------------------------------------
 (GCM) BUZDO(config)#
 (GCM) BUZDO(config)#interface loopback /LNo/                 (LNo = 0 - 2'147'483'647)
 (ICM) BUZDO(config-if)#
 (ICM) BUZDO(config-if)#ip address /Host-IP-adresa/ /255.255.255.255/
 (ICM) BUZDO(config-if)#no shutdown
 (ICM) BUZDO(config-if)#exit
 (GCM) BUZDO(config)#
---------------------------------------------------------------------------------------
 Defining networks of router (RIP, IGRP, EIGRP, OSPF)
-------------------------------------------------------
 (GCM) BUZDO(config)# 
 (GCM) BUZDO(config)#
 (GCM) BUZDO(config)#router /protocol/{opction}
 (GCM) BUZDO(config)#router rip
 (RCM) BUZDO(config-router)#version 2
 (RCM) BUZDO(config-router)#exit
 (GCM) BUZDO(config)#
 (GCM) BUZDO(config)#
 (GCM) BUZDO(config)#router igrp /AS/                                   (AS = 1-65'535)
 (GCM) BUZDO(config)#router eigrp /AS/
 (RCM) BUZDO(config-router)#
 (RCM) BUZDO(config-router)#network /NW-IP connected to IF/
 (RCM) BUZDO(config-router)#network /NW-IP connected to IF/
 (RCM) BUZDO(config-router)#network /NW-IP connected to IF/
 (RCM) BUZDO(config-router)#bandwidth /kbps/
 (RCM) BUZDO(config-router)#eigrp log-neighbor-changes
 (RCM) BUZDO(config-router)#exit
 (GCM) BUZDO(config)#
 (GCM) BUZDO(config)#                                              (WCM= WildCard Mask)
 (GCM) BUZDO(config)#router ospf /ID/
 (RCM) BUZDO(config-router)#network /NW-IP connected to IF/ /WCM/ area /ANo/
 (RCM) BUZDO(config-router)#
 (RCM) BUZDO(config-router)#                                            (ID = 1-65'535)
 (RCM) BUZDO(config-router)#                                    (ANo = 0-4'294'967'295)
 (RCM) BUZDO(config-router)#log-adjancency-changes
 (RCM) BUZDO(config-router)#end
 (GCM) BUZDO(config)#                                         (LNo = 0 - 2'147'483'647)
 (GCM) BUZDO(config)#interface loopback /LNo/ 
 (ICM) BUZDO(config-if)#ip address /Host-IP-address/ /255.255.255.255/
 (ICM) BUZDO(config-if)#                             (host mask for software interface)
 (ICM) BUZDO(config-if)#
 (ICM) BUZDO(config-if)#                                  (Router-ID = Host-IP-address)
 (ICM) BUZDO(config-if)#end
 (GCM) BUZDO(config)#
 (GCM) BUZDO(config)#<CTRL>+<Z>
 (PEM) BUZDO#copy running-config startup-config
 (PEM) BUZDO#
---------------------------------------------------------------------------------------
 HDLC encapsulation of a serial interface
-------------------------------------------
 BUZDO#
 BUZDO#configure terminal
 BUZDO(config)#
 BUZDO(config)#interface serial 0/0
 BUZDO(config-if)#encapsulation HDLC               (default on synchronous serial port)
 BUZDO(config-if)#no shutdown
 BUZDO(config-if)#<CTRL>+<Z>
 BUZDO#
---------------------------------------------------------------------------------------
 PPP encapsulation of a serial interface
------------------------------------------
 BUZDO#
 BUZDO#configure terminal
 BUZDO(config)#
 BUZDO(config)#username /name of 1. connected Router/ password /PASSWORD/
 BUZDO(config)#username /name of 2. connected Router/ password /PASSWORD/
 BUZDO(config)#
 BUZDO(config)#interface serial 0/0
 BUZDO(config-if)#ip address /IF-IP/ /SNM/
 BUZDO(config-if)#clockrate 64000                                        (only for DCE)
 BUZDO(config-if)#encapsulation PPP
 BUZDO(config-if)#
 BUZDO(config-if)#compress {predictor|stack}
 BUZDO(config-if)#ppp quality /Percentage/                       (Percentage = 1 - 100)
 BUZDO(config-if)#ppp multilink                                                (if has)
 BUZDO(config-if)#
 BUZDO(config-if)#ppp authentication pap 
 BUZDO(config-if)#ppp pap sent-username /name of connected Router/ password /PASSWORD/
 BUZDO(config-if)#no shutdown
 BUZDO(config-if)#<CTRL>+<Z>
 BUZDO#
 BUZDO(config-if)#ppp authentication chap        (should not be sent NAME and PASSWORD)
 BUZDO(config-if)#no shutdown
 BUZDO(config-if)#<CTRL>+<Z>
 BUZDO#copy running-config startup-config
 BUZDO#

---------------------------------------------------------------------------------------
 FR encapsulation of a serial interface
-----------------------------------------
 BUZDO#
 BUZDO#configure terminal
 BUZDO(config)#
 BUZDO(config)#interface serial 0/1                                               (DCE)
 BUZDO(config-if)#clock_rate 64000
 BUZDO(config-if)#encapsulation frame-relay ietf
 BUZDO(config-if)#bandwith 64
 BUZDO(config-if)#no keepalive                                  (there is no FR switch)
 BUZDO(config-if)#ip address /DCE-IF-IP/ /SNM/
 BUZDO(config-if)#frame-relay map ip /DTE-IF-IP/ /DLCI/ ietf broadcast
 BUZDO(config-if)#description PVC to the DTE connection
 BUZDO(config-if)#                                                    (DLCI = 16 - 992)
 BUZDO(config-if)#no shutdown
 BUZDO(config-if)#<CTRL>+<Z>
 BUZDO# (SNM = 225.225.225.0)
 BUZDO# 
 BUZDO# 
 BUZDO#configure terminal
 BUZDO(config)#
 BUZDO(config)#interface serial 0/0 (DTE)
 BUZDO(config-if)#encapsulation frame-relay ietf
 BUZDO(config-if)#bandwith 64
 BUZDO(config-if)#no keepalive                                  (there is no FR switch)
 BUZDO(config-if)#ip address /DTE-IF-IP/ /SNM/
 BUZDO(config-if)#frame-relay map ip /DCE-IF-IP/ /DLCI/ ietf broadcast
 BUZDO(config-if)#description PVC to the DCE connection
 BUZDO(config-if)#no shutdown
 BUZDO(config-if)#<CTRL>+<Z>
 BUZDO#copy running-config startup-config
 BUZDO#
---------------------------------------------------------------------------------------
 VLSM (supports /30; RIPv2; OSPF; EIGRP)
------------------------------------------
 BUZDO(config)#                                                 (/30 = 255.255.255.252)
 BUZDO(config)#interface serial 0/0                             (/24 = 255.255.255.  0)
 BUZDO(config-if)#ip address /IF-IP/ /255.255.255.252/          (/22 = 255.255.252.  0)
 BUZDO(config-if)
---------------------------------------------------------------------------------------
 VLAN at FE (supports isl|dot1q)
-------------------------------------
 BUZDO(config)#
 BUZDO(config)#interface fastethernet 0/0
 BUZDO(config-if)#full duplex
 BUZDO(config-if)#speed {10 | 100 | 1000}
 BUZDO(config-if)# 
 BUZDO(config-if)#ip address /IF-IP/ /SNM/
 BUZDO(config-if)#description LAN of BUZDo with TRUNK
 BUZDO(config-if)#interface fastethernet 0/0.1                        (0/0.1 - 0/0.255)
 BUZDO(config-subif)#description native VLAN 1
 BUZDO(config-subif)#encapasulation {isl|dot1q} /1/                    (VNo = 1 - 1000)
 BUZDO(config-subif)#ip address /LIF-IP/ /SNM/
 BUZDO(config-subif)#exit
 BUZDO(config-if)#
 BUZDO(config-if)#interface fastethernet 0/0.2
 BUZDO(config-subif)#description /something/
 BUZDO(config-subif)#encapasulation isl /VLNo/
 BUZDO(config-subif)#ip address /LIF-IP/ /SNM/
 BUZDO(config-subif)#exit
 BUZDO(config-if)#
 BUZDO(config-if)#interface fastethernet 0/0.3
 BUZDO(config-subif)#description /something/
 BUZDO(config-subif)#encapasulation isl /VLNo/
 BUZDO(config-subif)#ip address /LIF-IP/ /SNM/
 BUZDO(config-subif)#exit
 BUZDO(config-if)#
 BUZDO(config-if)#no shutdown
 BUZDO(config-if)exit
 BUZDO(config)#<CTRL>+<Z>
 BUZDO#copy running-config startup-config
 BUZDO#
---------------------------------------------------------------------------------------
 DHCP
-------------------------------------
 BUZDO(config)#
 BUZDO(config)#router ospf /ID/
 BUZDO(config-router)#network /NW-IP connected at IF/ /SNM/ area /ANo/
 BUZDO(config-router)#
 BUZDO(config-router)#                                                  (ID = 1-65'535)
 BUZDO(config-router)#                                          (ANo = 0-4'294'967'295)
 BUZDO(config-router)#log-adjancency-changes
 BUZDO(config-router)#end
 BUZDO(config)#
 BUZDO(config)#interface loopback /LNo/                       (LNo = 0 - 2'147'483'647)
 BUZDO(config-if)#ip address /Host IP address/ /255.255.255.255/
 BUZDO(config-if)#
 BUZDO(config-if)#                                        (Router-ID = Host-IP-address)
 BUZDO(config-if)#end
 BUZDO(config)# 
-------------------------------------
 BUZDO(config)# 
 BUZDO(config)#ip dhcp pool BUZDO
 BUZDO(dhcp-config)#network /NW-IP/ /SNM/
 BUZDO(dhcp-config)#default-router /FE-IF-IP/
 BUZDO(dhcp-config)#dns-server /IP-of-server/
 BUZDO(dhcp-config)#domain-name /IME_DOMENE.TIP/
 BUZDO(dhcp-config)#netbioas-name-server /IP of server/
 BUZDO(dhcp-config)#
 BUZDO(dhcp-config)#ip dhcp exclude-address /IP/ /IP/ ...
 BUZDO(dhcp-config)#
 BUZDO(dhcp-config)#exit
 BUZDO(config)#
 BUZDO(config)#no service dhcp
 BUZDO(config)#
 BUZDO(config)#service dhcp
 BUZDO(config)#
---------------------------------------------------------------------------------------
 NAT i PAT
-------------------------------------
 BUZDO(config)#
 BUZDO(config)#interface loopback /LNo/                       (LNo = 0 - 2'147'483'647)
 BUZDO(config-if)#ip address /Private-Host-IP-address/ /255.255.255.255/
 BUZDO(config-if)#
 BUZDO(config-if)#                                        (Router-ID = Host-IP-address)
 BUZDO(config-if)#end
 BUZDO(config)# 
----------------
 BUZDO(config)# 
 BUZDO(config)#ip route 0.0.0.0 0.0.0.0 /IP-NextHOP/
 BUZDO(config)#
 BUZDO(config)#interface fastethernet 0/0
 BUZDO(config-if)#ip address /Private-IP/ /Private-SNM/
 BUZDO(config-if)#ip nat inside                            (10.10.10.1 - 255.255.255.0)
 BUZDO(config-if)#no shutdown
 BUZDO(config-if)#exit
 BUZDO(config)#
 BUZDO(config)#interface serial 0/0
 BUZDO(config-if)#ip address /Public-IP/ /Public-SNM/
 BUZDO(config-if)#ip nat outside
 BUZDO(config-if)#no shutdown
 BUZDO(config-if)#exit
 BUZDO(config)#
----------------
 NAT - dynamic
----------------
 BUZDO(config)#                                                    (SLNo = 1 - onwards)
 BUZDO(config)#ip nat inside source list /SLNo/ pool /PUBLIC/
 BUZDO(config)#
 BUZDO(config)#ip nat pool /PUBLIC/ /First-public-IP/ /Last-public-IP/ /Public-SNM/
 BUZDO(config)#
 BUZDO(config)#access-list /SLNo/ permit /Private-NWIP/ /Private-ACL-Maska/
 BUZDO(config)#                                                (10.10.10.0 - 0.0.0.255)

 BUZDO(config)#
----------------
 NAT - static
----------------
 BUZDO(config)#
 BUZDO(config)#ip nat pool inside source static /Private-Host-IP/ /Public-Host-IP/
 BUZDO(config)#                                                 (addresses out of pool)
----------------
 PAT
----------------
 BUZDO(config)#
 BUZDO(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0
 BUZDO(config)#
 BUZDO(config)#access-list /SLNo/ permit /Private-NWIP/ /Private-ACL-Mask/
 BUZDO(config)#                                                (10.10.10.0 - 0.0.0.255)
 BUZDO(config)#
 BUZDO(config)#ip nat inside source list /SLNo/ interface serial 0/0 overload
 BUZDO(config)#
---------------------------------------------------------------------------------------
 Access lists (IP  standard         1-99 , IP  Extended   100-199)
              (IPX standard       800-899, IPX Extended   900-999) 
              (IPX SAP standard  1000-1099)
 -------------------------------------------------------------------
 any      = 0.0.0.0 255.255.255.255
 host     = /IP-hosta/ 0.0.0.0       (allows only one IP address)
 standard = as close to the destination
 extended = as close to the source
--------------------------------------------------------------------
 BUZDO(config)#
 BUZDO(config)#access-list /StLNo/ {permit | deny} /Source-IP/ /WildCard-MASK/
 BUZDO(config)#access-list /StLNo/ permit host /IP/
 BUZDO(config)#
 BUZDO(config)#                                                (protocol = IP, IPX ...)
 BUZDO(config)#
 BUZDO(config-if)#/protocol/ access-group /StLno/ {out | in} 
 BUZDO(config-if)#IP access-group /StKLno/ {out | in}
 BUZDO(config)#
 BUZDO(config)#no access-list /StLNo/                      (operator = lt, gt, eq, neq)
 BUZDO(config)#
 BUZDO(config)#access-list /ExtLNo/ {permit | deny} /protocol/
 /Izvorna-IP//I-WCM/ /Odredišna-IP//O-WCM/ /operator/ /port/
 /established/
 BUZDO(config)#
 BUZDO(config-if)#IP access-group /ExtLNo/ {out | in}
 BUZDO(config)#
 BUZDO(config)#no access-list /StLNo/ 
 BUZDO(config)#
 BUZDO(config)#line vty 0 4
 BUZDO(config-line)#password /somethin/
 BUZDO(config-line)#login
 BUZDO(config-line)#access-class /StLno/ in
 BUZDO(config)#
----------------
 ISDN
----------------
 BUZDO(config)#dialer-list, protocol ip permit
 BUZDO(config)#
 BUZDO(config)#isdn switch /type/ or
 BUZDO(config-if)#isdn switch /type/
 BUZDO(config-if)#
 BUZDO(config-if)#
 BUZDO(config-if)#                                    (minimum three commands for link)
 BUZDO(config-if)#encapsulation PPP
 BUZDO(config-if)#dialer-group /No/
 BUZDO(config-if)#IP address /IP-address//Subnet-MASK/
 BUZDO(config)#
 BUZDO(config)#
 BUZDO(config)#
 BUZDO(config)#controler {T1-E1,slot | port}
 BUZDO(config-controler)#pro-groupe timeslot /range/
 BUZDO(config-controler)#framing /parameters/
 BUZDO(config-controler)#linecode /parameters/
 BUZDO(config-controler)#interface serial /parameters/
 BUZDO(config)#
--------------------------
 FR (serial interface)
--------------------------
 BUZDO(config)#                                                     (DLCI-No = 0- 1023)
 BUZDO(config)#                                             (because of LMI = 16 - 992)
 BUZDO(config)#encapsulation frame-relay {cisco | ietf}
 BUZDO(config)#IP address /IP-adresa//Subnet-MASK/ /DLCI-No/ static
 BUZDO(config)#
 BUZDO(config)# (protocol = IP, IPX)
 BUZDO(config)#frame-relay map /protocol/ /IP-address/ /DLCI-No/ broadcast
 BUZDO(config)#
 BUZDO(config)#frame-relay lmi-type {cisco | ansi | q933a} 
=======================================================================================
=======================================================================================
 Commands for configuring of Cisco Cisco switch
=======================================================================================
 Commands insight into the configuration
-----------------------------------------
 (PEM) SWITCH#show version
 (PEM) SWITCH#show startup-config                                               (NVRAM)
 (PEM) SWITCH#show run
 (PEM) SWITCH#show running-config                                                 (RAM)
 (PEM) SWITCH#show cdp
 (PEM) SWITCH#show cdp neighbors
 (PEM) SWITCH#dir flash
 (PEM) SWITCH#show flash
 (PEM) SWITCH#show ip
 (PEM) SWITCH#show vlan id {VNo}                                       (VNo = 1 - 1005)
 (PEM) SWITCH#show vlan name /name of VLAN/
 (PEM) SWITCH#show interface fastethernet x/y
 (PEM) SWITCH#show ip interface vlan /VNo/
 (PEM) SWITCH#show mac-address-table
 (PEM) SWITCH#
 (PEM) SWITCH#
---------------------------------------------------------------------------------------
 Initial setup of  switch
----------------------------------
 (UEM) SWITCH>enable
 (PEM) SWITCH#show running-config
 (PEM) SWITCH#configure terminal
 (GCM) SWITCH(config)#
 (GCM) SWITCH(config)#hostname TUPKO
 (GCM) TUPKO(config)#
 (GCM) TUPKO(config)#ip host /name of 1. Router/ /IP of 1. Router/
 (GCM) TUPKO(config)#ip host /name of 2. Router/ /IP of 2. Router/
 (GCM) TUPKO(config)#ip host /name of 1. Switch/ /IP of 1. Switch/
 (GCM) TUPKO(config)#
 (GCM) TUPKO(config)#ip http server
 (GCM) TUPKO(config)#ip http port 80
 (GCM) TUPKO(config)#exit

---------------------------------------------------------------------------------------
 Password for GCM, console and modem
-------------------------------------
 (PEM) TUPKO#
 (PEM) TUPKO#configure terminal
 (GCM) TUPKO(config)#enable password PASSWORD_1
 (GCM) TUPKO(config)#enable secret PASSWORD_2
 (GCM) TUPKO(config)#exit
 (PEM) TUPKO#
 (GCM) TUPKO(config)#line con 0
 (LCM) TUPKO(config-line)#password PASSWORD_3
 (LCM) TUPKO(config-line)#login
 (LCM) TUPKO(config-line)#<CTRL>+<Z>
 (PEM) TUPKO#
 (GCM) TUPKO(config)#line vty 0 15
 (LCM) TUPKO(config-line)#password PASSWORD_4
 (LCM) TUPKO(config-line)#login
 (LCM) TUPKO(config-line)#<CTRL>+<Z>
 (PEM) TUPKO#configure terminal
 (GCM) TUPKO(config)#
 (GCM) TUPKO(config)#interface VLAN1
 (ICM) TUPKO(config-if)#ip address /Switch-IP//SNM/
 (ICM) TUPKO(config-if)#duplex full
 (ICM) TUPKO(config-if)#speed 100
 (ICM) TUPKO(config-if)#
 (ICM) TUPKO(config-if)#no shutdown
 (ICM) TUPKO(config-if)#ip default-gateway /IP/
 (ICM) TUPKO(config-if)#<CTRL>+<Z>
 (PEM) TUPKO#
---------------------------------------------------------------------------------------
 Saving the configuration at NVRAM
-----------------------------------
 (PEM) TUPKO#copy running-config startup-config                             (RAM-NVRAM)
 (PEM) TUPKO#copy run start
 (PEM) TUPKO#reload
---------------------------------------------------------------------------------------
 Configuring of switch
--------------------------
 (PEM) TUPKO#
 (PEM) TUPKO#delete flash:vlan.dat
 (PEM) TUPKO#erase startup-config                                      (erase of NVRAM)
 (PEM) TUPKO#reload
 (UEM) TUPKO>enable
 (PEM) TUPKO#clear mac-address-table {dynamic}
 (PEM) TUPKO#configure terminal
 (GCM) TUPKO(config)#
---------------------------------------------------------------------------------------
 Setting up GW and VLAN-1   (default)
----------------------------------------
 TUPKO#
 TUPKO(config)#ip default-gateway /IP-FE at Router/
 TUPKO(config)#interface VLAN 1
 TUPKO(config-if)#ip address /IP of the network - best choice is last/ /SNM/
 TUPKO(config-if)no shutdown
 TUPKO(config-if)#<CTRL>+<Z>
 TUPKO#
---------------------------------------------------------------------------------------
 Static MAC address
-------------------------------------
 TUPKO#
 TUPKO(config)#mac-address-table static AAAA.AAAA.AAAA fastethernet x/y vlan 1
 TUPKO(config)#
 TUPKO(config)#<CTRL>+<Z>
 TUPKO#
---------------------------------------------------------------------------------------
 Port security
-------------------------------------
 TUPKO#
 TUPKO(config)#interface fastethernet x/y
 TUPKO(config-if)#switchport mode {access | dinamic | trunk}
 TUPKO(config-if)#switchport mode access
 TUPKO(config-if)#switchport port-security { | | | }
 TUPKO(config-if)#<CTRL>+<Z>
 TUPKO#
---------------------------------------------------------------------------------------
 Port TRUNK
-------------------------------------
 TUPKO#
 TUPKO(config)#interface fastethernet x/y
 TUPKO(config-if)#switchport mode trunk
 TUPKO(config-if)#switchport trunk encapsulation {isl | dot1q}
 TUPKO(config-if)#switchport trunk allowed vlan all
 TUPKO(config-if)#<CTRL>+<Z>
 TUPKO#
---------------------------------------------------------------------------------------
 Port VLAN 
-------------------------------------
 TUPKO#
 TUPKO#vlan database
 TUPKO(vlan)#show
 TUPKO(vlan)#
 TUPKO(vlan)#vtp {server | client}
 TUPKO(vlan)# (VLNo = 1 default)
 TUPKO(vlan)#vlan /VLNo1/ name /1. name/                              (VLNo = 2 - 1001)
 TUPKO(vlan)#vlan /VLNo2/ name /2. name/                         (VLNo > 1001 reserved)
 TUPKO(vlan)#vlan /VLNo3/ name /3. name/
 TUPKO(vlan)#
 TUPKO(vlan)#no vlan /VLNo/
 TUPKO(vlan)#
 TUPKO(vlan)#show
 TUPKO(vlan)#applay
 TUPKO(vlan)#exit
 TUPKO#
 TUPKO(config)#interface fastethernet x/y
 TUPKO(config-if)#switchport mode access
 TUPKO(config-if)#switchport access vlan /VLNo/
 TUPKO(config-if)#<CTRL>+<Z>
 TUPKO#
 TUPKO(config)#interface fastethernet x/y
 TUPKO(config-if)#no switchport mode access
 TUPKO(config-if)#no switchport access vlan /VLNo/
 TUPKO(config-if)#<CTRL>+<Z>
 TUPKO#
=======================================================================================

Commands are not the same as described for all types of devices, but according to the approach and its use can be concluded that they belong to the same family unit. Manufacturer periodically for your IOS make improvements that issue once and sometimes offers free of charge, as well as new versions of the operating system, which depends on the content of the agreement entered into when purchasing network equipment. Not good not to secure their support for at least a couple of years.




 Home Page
 Extras  Informatics Alphabet
 
Citing this page:
Radic, Drago. " IT - Informatics Alphabet " Split-Croatia.
{Date of access}. <http://www.informatics.buzdo.com/specific/>.
Copyright © by Drago Radic. All rights reserved. | Disclaimer